Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Omnilogic showing clean t-cell 15 warning, but I just cleaned it

  1. Back To Top    #1

    Omnilogic showing clean t-cell 15 warning, but I just cleaned it

    Hello,

    Late last year we put in a new pool. Two weeks ago I went to clean the SWG for the first time. It wasn't very dirty but it had been 5 months since it was installed. So I cleaned it, put it back, everything is working great.

    This week I received two warnings from the Omnilogic system to clean the SWG. I am trying to figure out why. When I initially cleaned it I did not see a reset button or anything to reset the 500 hour countdown to the next cleaning. I am assuming this is why I am getting the warning, but I am not sure. Searching on the internet shows that there is an inspect cell LED and a reset button but doesn't show a picture of where the dang thing is. I am thinking this may be just for older systems but I am not sure.

    Here is where I found the info: How to Reset Inspect Cell Light - Hayward POOLSIDE Blog

    Here is the warning: (I just "cleared" it to see if it would come back)
    Capture.jpg


    Thanks,
    CF
    My equipment: ~20,000 gal free form in ground pool with mini pebble finish and 3 vertical decents. Hayward Omnilogic controller. Hayward Goldline T Cell 15, Hayward Swim Clear cartridge filter 520sq ft, Hayward H-series 400,000 BTU heater, Hayward Navigator pool cleaner, 3 Color Logic LED lights. Pic Vid

  2. Back To Top    #2

    Re: Omnilogic showing clean t-cell 15 warning, but I just cleaned it

    The inspect cell light is for the AquaRite, not OmniLogic.

    Select diagnostics (shown on screen) and then click the reset timer button (last column, bottom number).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •