Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Poolvergnugen The Pool Cleaner strangeness

  1. Back To Top    #1

    Join Date
    Jan 2016
    Jackson, ca

    Poolvergnugen The Pool Cleaner strangeness

    Hello everyone,

    I have a 2-wheel, suction side Poolvergnugen The Pool Cleaner unit… Had it quite some time now and have maintained it carefully. According to my local pool supply lady, I’ve replaced everything that can be replaced within the last 24 months. Visually, the mechanisms all appear to be in good working condition, gears are not worn either in the gearbox, the drive shafts or on the wheels, I just bought a new set of wheel hubs and tires this year. All the driveshafts have been replaced.

    My problem is the unit has no power when traveling forward. Trying to climb out of the deep end of the pool or running in to a wall cause the wheels to stop. The unit will spin around, and it does so with power… when its spinning I cannot stall the wheels by trying to grab on to the tires. Soon as its done spinning, the unit stalls again, unless it happens to be pointed downhill.

    What part of the mechanism would be the cause of this kind of behavior?

  2. Back To Top    #2

    Join Date
    Jan 2013
    Long Island, NY

    Re: Poolvergnugen The Pool Cleaner strangeness

    Here's a vid of a rebuild. Does everything in the vid match what you replaced? Put back in the same positions? Also, check the suction flow. Maybe you adjusted it on accident and the wheel RPM's are too low. That will stop it from climbing walls and from getting out of the deep end.

    Doughboy 12' x 20' Saphire semi-AG, Installed 2012
    Waterway 1.5 HP 2 speed, 100 sqft cartridge filter
    Aprox 7000 Gal, Full sun, 85K heat pump,
    TF-100 test kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts