Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 17 of 17

Thread: Swim pure plus comes on, turns off

  1. Back To Top    #1

    Join Date
    Sep 2015
    Location
    Fl
    Posts
    18

    Swim pure plus comes on, turns off

    Ok, I have seen similar threads on here, with possible solutions of replacing the thermistor, but it seemed that those people that fixed their problem with that solution were getting no power whatsoever .

    Problem: noticed today pool was greening , was surprised since the swim pure supposedly said my salt was at 3600 ( hasn't changed in a while).
    Looked at control unit and the "power" and "generating" would come on, stay on for 4-5 seconds, you would hear an audible click , and the lights would go out. Wait 30 seconds and it comes back on again, and repeat ad nauseam. When the lights go off however, there IS still power to the unit, because I can cycle through the diagnostics. The cell voltage display will count up while the lights are off, then when it turns on the voltage drops very low, then repeats. Appears that there is no cell current based on the diagnostic display, regardless of whether generating light is on at the moment or not. Instant salt is minuscule. Just replaced flow switch within last 6 months. I pulled the cell off (t-9) and it looks like it is perfectly clean, though it's got to be a few years old ( we bought house one year ago with this cell in use already).

    So..... It has power, it's turning itself off and on at specific intervals, so it doesn't seem like a short . Is it the cell or this elusive thermistor? I don't have money to just wildly nilly buy a cell if that's not problem. I can *probably* replace a part if all it requires is a bit of soldering .

    Advice please?

  2. Back To Top    #2

    Re: Swim pure plus comes on, turns off

    Can you post the diagnostics?

    Are any of the warning lights on?

  3. Back To Top    #3

    Join Date
    Sep 2015
    Location
    Fl
    Posts
    18

    Re: Swim pure plus comes on, turns off

    Quote Originally Posted by JamesW View Post
    Can you post the diagnostics?

    Are any of the warning lights on?

    No no warning lights at all.

    3600
    80
    voltage hits about 20 before it comes on and drops down to 1 or 2
    0 current
    100p
    -0
    al-0
    r 1.58
    t-9

    - - - Updated - - -

    And even though instant salinity is a 0 there is no "low salt" warning light. I have not had my water tested to see what is correct and what isn't .

  4. Back To Top    #4
    Mod Squad tim5055's Avatar
    Join Date
    May 2014
    Location
    Columbia, SC
    Posts
    8,494

    Re: Swim pure plus comes on, turns off

    I can't help with the SWG, but if it truly started greening you want to SLAM with liquid to get it back in shape. Which also points out one of the core values around here - regular accurate testing.
    TFP Moderator 39 X 18 23,000(ish) freeform gunite; built 2007ish; Pentair Triton II TR100 600lb Sand filter; 2 HP Pentair pump with 2.2 HP AO Smith single speed motor; 2 skimmers, 1 main drain, 4 returns w/waterfall, Stenner 45MHP2 3GPD running@ 60% - 15 gal Tank; heated by the sun CYA 200+ when I started - 50 now. Dolphin Supreme M5 Pool Cleaner. Hot Springs SX Spa, 285 gallon

  5. Back To Top    #5

    Re: Swim pure plus comes on, turns off

    It's a bad thermistor. Part number AS32 2R025.

  6. Back To Top    #6

    Join Date
    Sep 2015
    Location
    Fl
    Posts
    18

    Re: Swim pure plus comes on, turns off

    Well....at least it's not the cell then. Seems like it is fairly easy for even a rookie to replace this part ?
    Anything I should know?

    Thanks for the definitive answer! I'm off to purchase a solder gun it appears

  7. Back To Top    #7

    Re: Swim pure plus comes on, turns off

    It's not too difficult. Get a desoldering tool to suck up the used solder. There's a bulb type and a plunger type.

    1) Cut off the old thermistor at the top of the legs.
    2) Desolder each leg separately.
    3) Melt the old solder over each hole and suck it up with the desoldering tool.
    4) Cut the new thermistor's legs down some (They're a bit too long and the front panel will hit the thermistor if it's sticking up too high. )
    5) stick the legs through the holes and solder the new thermistor in place.

    Once you get the new part in, the voltage should be 30 to 32 when off and 24 to 29 when on. To check the cell, check the instant salt and compare it to the actual salt level as verified by a reliable test. I would suggest the k-1766.

  8. Back To Top    #8

    Join Date
    Sep 2015
    Location
    Fl
    Posts
    18

    Re: Swim pure plus comes on, turns off

    Great. So this is definitely the issue, the bad thermistor is not allowing the cell to operate ? I appreciate all the info, relieved I don't have to spend $400 on a new cell.

  9. Back To Top    #9

    Re: Swim pure plus comes on, turns off

    It's a bad thermistor. This is a common problem for these units. It's pretty much the only weak spot they have.

    As far as the cell, you need to check the instant salt againt the actual salt once the thermistor is fixed. The cell might be bad or underperforming.

  10. Back To Top    #10

    Join Date
    Sep 2015
    Location
    Fl
    Posts
    18

    Re: Swim pure plus comes on, turns off

    Ok great. Thanks again.

  11. Back To Top    #11

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,077

    Re: Swim pure plus comes on, turns off

    Don't overlook Tim5055's advice.....your SWG, even when it's fixed, will not easily overcome your green pool.

    I would get that pool cleaned right back up and then allow your newly repaired SWG to keep it that way.
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

  12. Back To Top    #12

    Join Date
    Sep 2015
    Location
    Fl
    Posts
    18

    Re: Swim pure plus comes on, turns off

    Ok, so I ordered a new thermistor, and after seeing how basic my soldering skills were, took the board to a computer repair place and let them soldered the piece on. Just got the board hook back up finally today, turned it on, and .....

    And I don't know. The display is reading COLD because the water temp is so cold. I've got the solar heater going and trying to bring the water temperature up a few degrees. The part that worries me is that the "no flow" light is on. Is that normal since water is so cold? The water is obviously flowing, the returns are all working good, and the flow switch was working fine ( it was only a few months old before this issue ) before I pulled the board out.

    do I have reason to be worried, is there more problems in my future, or should it resolved when the water temperature improves?

  13. Back To Top    #13

    Re: Swim pure plus comes on, turns off

    Most likely, the no flow condition is just a bad connection. Try unplugging the flow sensor and reinserting it. The cold indicator is normal and will go away with warmer water.

    What are the current diagnostic readings?

  14. Back To Top    #14

    Join Date
    Sep 2015
    Location
    Fl
    Posts
    18

    Re: Swim pure plus comes on, turns off

    Quote Originally Posted by JamesW View Post
    Most likely, the no flow condition is just a bad connection. Try unplugging the flow sensor and reinserting it. The cold indicator is normal and will go away with warmer water.

    What are the current diagnostic readings?
    I'll try that when I get home. I'll also post diagnostics , I left for work after installing it this morn.

    thx

  15. Back To Top    #15

    Join Date
    Sep 2015
    Location
    Fl
    Posts
    18

    Re: Swim pure plus comes on, turns off

    Ok guys, so I was out of town, but still getting no flow even though water has warmed nicely now. Here's the numbers :

    3600
    69
    33
    0
    52p
    -0
    Al-0
    r 1.58
    T-9

    I removed my flow switch and reinserted . Upon examining the switch , it appears....melted. On top where the wire is, there is a furrow melted into the top where the wire was touching and discoloration to the wire. Obviously switch needs to be replaced ( just did in September) , but is there an underlying cause that will do this again , or was it because of the other piece that did this? I'm gonna try and upload a photo ...

    - - - Updated - - -

    image.jpg

  16. Back To Top    #16

    Re: Swim pure plus comes on, turns off

    The voltage is now good, so the unit should work once the flow switch is working. Not sure why it went bad.

    What does the plug end look like?

  17. Back To Top    #17

    Join Date
    Sep 2015
    Location
    Fl
    Posts
    18

    Re: Swim pure plus comes on, turns off

    The plug end is completely normal , normal phone cord style plug.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •