Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Hello! Newbie from WI

  1. Back To Top    #1

    Join Date
    Nov 2015
    Milwauee, WI

    Hello! Newbie from WI

    Hi there! I'm JD. Just throwing out an intro. A friend of mine wanted to get rid of his '99 Hot Springs Grandee hot tub so I took it off his hands. I knew it was going to require some work to get running so I've been doing a lot of research on hot tub repair and saw this forum. I signed up since I know I'll be coming back with questions but so far everything has been going well. First time we powered it up something was obviously wrong when I heard a banging/slamming sound from the pump after a few seconds and then the thermostat tripped and turned off. It was obvious the circulation pump was shot. So I bought a new one and replaced it last night and it was running great. The thing also has some leaks so we put in the Fix-a-Leak last night as a first step to see what it'll fix. I noticed there was no water loss over night which was good and one of the leaks that was dripping from the drain is now fixed. I'm sure there's going to be more once we fire up the jets again. I also noticed 2 of the air lines were disconnected and the barbs for the check-valve broke off so I've got 2 replacements coming in the mail as well. I noticed one of my jets is constantly shooting full air regardless of the valve setting so I'm assuming the air line came loose. I'll probably be taking the side panels off and digging through the foam (if this tub is spray foamed, can't actually tell yet) and getting to the back of the jet to see what's going on. Another jet was missing a piece so I ordered that replacement as well. A handful of problems so far but they seem manageable. Hopefully can get it running before it gets too cold!
    -1999 Hot Springs Grandee above ground-

  2. Back To Top    #2
    Mod Squad Texas Splash's Avatar
    Join Date
    Jun 2014
    South-Central Texas, Marion/San Antonio

    Re: Hello! Newbie from WI

    Sounds like you have your hands full, but at the same time you are a DIY'er, so that's always good. Welcome to TFP JD.
    Pat (a.k.a. Texas Splash) ~ My Pool: Viking Fiberglass; 17,888 Gal; Waterway Supreme 2-sp/2-hp pump; Hayward Ctg filter; TF-100 w/ Speed Stir
    If you enjoyed your TFP experience, please consider donating to Support TFP!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts