Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Delozone Eclipse 1

  1. Back To Top    #1
    Jackiesorenson's Avatar
    Join Date
    Sep 2015
    San Antonio TX

    Delozone Eclipse 1

    Since replacing my pool pump, I noticed my Delozone Ozonator was not lit. We checked and there is no power at the J box that feeds the ozonator nor inside the Jandy Aqualink at the terminals where it is wired into. Other terminals inside the Jandy Aqualink box are showing power and of course, are operating my equipment--except the ozonator. We have had 3 people come out and give us estimates on the pump replacement, and they all opened the Jandy Aqualink box. Is it possible something is just loose? Any recommendation is appreciated.
    Sorenson Blue Lagoon

  2. Back To Top    #2

    TFP Guide
    domct203's Avatar
    Join Date
    Jun 2015

    Re: Delozone Eclipse 1

    I would call whoever replaced the pump and tell them to check their work.

    Are you 100% certain it was working before the pump replacement?


    - - - Updated - - -

    Where are my manners? Welcome to TFP!
    Dom - TFP Guide
    Intex 18' X 48" Ultra Frame AGP 6700 gallons | Hayward Pro Series 21" Sandfilter | Hayward 1.5HP Power Flo Matrix pump | Hayward Thru-wall Skimmer | Wanda the Whale | 72 sq ft of Sungrabber Solar Panels | Taylor K2006 Test Kit, Sample Sizer & Speed Stir | Click Here To Become a TFP Supporter!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts