Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 7 of 7

Thread: Hot Springs Grandee Control panel flashing solid colors

  1. Back To Top    #1
    wpbucher's Avatar
    Join Date
    Feb 2012
    Location
    South-Central Pennsylvania
    Posts
    132

    Hot Springs Grandee Control panel flashing solid colors

    Hi,

    In the summer, we use our pool and spillover spa. I closed the Hot Springs spa in May. I followed the winterizing instructions in the owners manual except for adding antifreeze. No need since I knew I would open before a frost.

    I filled the tub. When I flipped the circuit breakers to provide power, the display is displaying a solid color (blue, green, orange, white, etc). It just keeps repeating. Each color is displayed for maybe a second.

    I pressed the JETS button and the jets work. I tried the lights... I don't think they are working....not sure since the screen is unusable.

    Eventually the screen goes black (just like it would under normal use). When I press a button, the colors start to display again.

    When jets are off the filter pump is running.

    Any idea what is the problem and solution?

    Thanks TFP!!!
    2013 HotSpring Grandee with Ace Sanitizing System
    25K IG vinyl pool with Alps spillover spa and waterfall. Build Date: June 2013
    Triton II TR100 Sand Filter, Pentair Master Temp 400 natural gas pool heater, Intellichlor SWG, Rainbow Chlorine Feeder
    Pentair VF filter pump, WhisperFlo 2 hp WFE-8 waterfall pump, WhisperFloFX 2 hp spillover spa pump
    Intellibrite 5G (2 pool and 1 in spa) lights :: TFT-100 test kit, Taylor K-1776 test kit

  2. Back To Top    #2
    wpbucher's Avatar
    Join Date
    Feb 2012
    Location
    South-Central Pennsylvania
    Posts
    132

    Re: Hot Springs Grandee Control panel flashing solid colors

    Just went out and checked spa. Screen was upside down and in French. I was, however, able to change to English. Looks like I'm in business. Not sure what was going on with the screen.
    2013 HotSpring Grandee with Ace Sanitizing System
    25K IG vinyl pool with Alps spillover spa and waterfall. Build Date: June 2013
    Triton II TR100 Sand Filter, Pentair Master Temp 400 natural gas pool heater, Intellichlor SWG, Rainbow Chlorine Feeder
    Pentair VF filter pump, WhisperFlo 2 hp WFE-8 waterfall pump, WhisperFloFX 2 hp spillover spa pump
    Intellibrite 5G (2 pool and 1 in spa) lights :: TFT-100 test kit, Taylor K-1776 test kit

  3. Back To Top    #3

    Join Date
    Aug 2015
    Location
    Maine
    Posts
    45

    Re: Hot Springs Grandee Control panel flashing solid colors

    My tiger river, made by hot springs (Watkins) randomly does the same thing. Typically I kill the power, wait a few moments for any trace power to dissipate and reapply power. That usually does the trick.

  4. Back To Top    #4
    wpbucher's Avatar
    Join Date
    Feb 2012
    Location
    South-Central Pennsylvania
    Posts
    132

    Re: Hot Springs Grandee Control panel flashing solid colors

    This morning I went out to check water chemistry. When I dipped the sample container, I could tell the temp was not 98 degrees. I pressed the back button and the solid-color-show-for-a-second-display was back. I shut off the power and waited about 10 seconds. Did not fix.

    Any ideas as to why...and a permanent solution?

    Thanks TFP!!!
    2013 HotSpring Grandee with Ace Sanitizing System
    25K IG vinyl pool with Alps spillover spa and waterfall. Build Date: June 2013
    Triton II TR100 Sand Filter, Pentair Master Temp 400 natural gas pool heater, Intellichlor SWG, Rainbow Chlorine Feeder
    Pentair VF filter pump, WhisperFlo 2 hp WFE-8 waterfall pump, WhisperFloFX 2 hp spillover spa pump
    Intellibrite 5G (2 pool and 1 in spa) lights :: TFT-100 test kit, Taylor K-1776 test kit

  5. Back To Top    #5
    wpbucher's Avatar
    Join Date
    Feb 2012
    Location
    South-Central Pennsylvania
    Posts
    132

    Re: Hot Springs Grandee Control panel flashing solid colors

    I also tried shutting off for 2 minutes. Did not fix. The salt cell on my tub is kaput. I have a new one. I was waiting to install until I got the chemistry perfect. Now I'm glad I didn't, because that just adds another variable. Unless, the bad cell has something to do with the display.

    It is very strange that when it started to work....it just started to work. I didn't power it down....it just started working. I wonder what triggered it to stop working during the night?

    Any help appreciated.
    2013 HotSpring Grandee with Ace Sanitizing System
    25K IG vinyl pool with Alps spillover spa and waterfall. Build Date: June 2013
    Triton II TR100 Sand Filter, Pentair Master Temp 400 natural gas pool heater, Intellichlor SWG, Rainbow Chlorine Feeder
    Pentair VF filter pump, WhisperFlo 2 hp WFE-8 waterfall pump, WhisperFloFX 2 hp spillover spa pump
    Intellibrite 5G (2 pool and 1 in spa) lights :: TFT-100 test kit, Taylor K-1776 test kit

  6. Back To Top    #6

    Join Date
    Aug 2015
    Location
    Maine
    Posts
    45

    Re: Hot Springs Grandee Control panel flashing solid colors

    It sounds like the recirc pump has failed considering the jet pump still works. If the recirc pump is not running, the heater will not work. Do you have ozone? Are there bubbles coming out?

  7. Back To Top    #7
    wpbucher's Avatar
    Join Date
    Feb 2012
    Location
    South-Central Pennsylvania
    Posts
    132

    Re: Hot Springs Grandee Control panel flashing solid colors

    The recirc pump is running. I called service and a tech came out. He stated, "They do this sometimes". He switched out the board and all is well. I have had the spa for 23 months.
    2013 HotSpring Grandee with Ace Sanitizing System
    25K IG vinyl pool with Alps spillover spa and waterfall. Build Date: June 2013
    Triton II TR100 Sand Filter, Pentair Master Temp 400 natural gas pool heater, Intellichlor SWG, Rainbow Chlorine Feeder
    Pentair VF filter pump, WhisperFlo 2 hp WFE-8 waterfall pump, WhisperFloFX 2 hp spillover spa pump
    Intellibrite 5G (2 pool and 1 in spa) lights :: TFT-100 test kit, Taylor K-1776 test kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •