Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Problem Jandy 1400 Salt Cell - Error 121

  1. Back To Top    #1

    Join Date
    Oct 2015
    Fort Worth TX

    Problem Jandy 1400 Salt Cell - Error 121

    Hello Everyone,

    I am having some issues with my AquaPure 1400 salt cell. It was previously giving me some codes that the sensor was bad over the summer. I replaced this about a month ago and everything was fine. Now I am getting a 121 error. I have cleaned the cell numerous times and it is pretty clean. What is frustrating is that some days it works all day and others it codes and does not product chlorine all day. The cell is about three years old, but wanted to see if I could get through the winter if possible before buying a new cell. Your thoughts and help would be greatly appreciated.
    Salt pool 32,000 Gal
    Peble tech bottom
    six years old
    Jandy Aqualink RS
    Jandy 1400 Salt Cell

  2. Back To Top    #2

    Re: Problem Jandy 1400 Salt Cell - Error 121

    120 and 121 indicate low current. Possibly due to low salt, a bad cell cord or a failing cell. First try a new cord and make sure the salt is good.

  3. Back To Top    #3

    In the Industry

    Join Date
    Mar 2015
    New Orleans, LA

    Re: Problem Jandy 1400 Salt Cell - Error 121

    If cell has white stuff on it clean it with the acid and water. If not it is probably time to replace it. That code states clean or replace. If the water is going to get in the 60s it will need very little chlorine so you could get by with adding in winter and put on a new cell before summer.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts