Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Hayward« Aqua Rite PCB replacement issues

  1. Back To Top    #1

    Join Date
    Oct 2015
    Pasadena, TX

    Hayward« Aqua Rite PCB replacement issues

    I've replaced both pcb boards in my salt control panel and still don't get anything on the readouts and no lights are visible. It's like there is no power but I checked and there is power to the unit. Could the transformer be bad?
    Attached Images Attached Images
    In ground pool with spa
    iAqualink Salt system
    20,000 gallons

  2. Back To Top    #2

    Re: Hayward« Aqua Rite PCB replacement issues

    Google aquarite diagnostics manual.

  3. Back To Top    #3

    In the Industry
    ps0303's Avatar
    Join Date
    Jul 2011

    Re: Hayward« Aqua Rite PCB replacement issues

    Well did you check to see if you were getting power out of the transformer? If not, that's what you need to do next.

    A word of caution: When working with gas and electrical you might want to consider a licensed contractor. Consider the value of your life and others around you.

  4. Back To Top    #4
    chiefwej's Avatar
    Join Date
    Jun 2011

    Re: Hayward« Aqua Rite PCB replacement issues

    Is there a fuse anywhere? Make sure that power is actually getting to the transformer. Then test to see if power is coming out of the transformer. After that it goes to the main PC board, which you say is new. If it weren't I'd be looking at the input resistor (thermistor).
    Tucson, AZ
    19k gallon Pebble Tec play pool/spa, Pentair Intelliflo VS (3 hp) 011018, Super II 2hp (for spa), Aqua Rite T-15 SWG, Pro Grid 60 DE filter, Hayward H400 & Heliocol Solar heating, A&A infloor system, fill water w/high CH and TA, 50 ppm borates,TF-100 test kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts