Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Aqua Rite Reading "Cold"

  1. Back To Top    #1

    Join Date
    Jun 2013
    Plano, TX

    Question Aqua Rite Reading "Cold"

    Hello - my Aqua Rite display has been regularly displaying "Cold" for about a month. I've successfully re-set the display to the correct readings each time, but it eventually goes back to showing "Cold." Since it's not generating, I've been using bleach to maintain FC levels. I've taken the cell into the pool store for testing, and the tests are indicating that the cell is working. I've also inspected the circuit boards inside the salt chlorinator box and they look like new, and there are no insects or debris inside the box. The salt chlorinator box is the original and was installed in 2004.

    I also found a page on the Goldline Controls website -

    This page contains information on settings and troubleshooting for the aqua rite. The page says that if when you unplug the salt cell from the box and the temperature display reads 77, it's probably a problem with the cell. When I unplugged the cell, my temperature reading changed to 77 (from -5). I've seen in other threads on this site that if the temp sensor in the cell fails, then the entire cell must be replaced. Does anyone know that for sure? Can anyone confirm that the salt cell test can indicate that the cell is working even with a failed temperature sensor? Based on my description, does anyone have any suggestions as to what I should do next?

    33,000 gal, IG/plaster, spa/waterfall combo plus waterfall
    Hayward DE filter 72 ft, 2.0 HP Hayward Tristar pump
    1.5 HP Hayward Northstar pump for waterfall, SWG,
    Polaris 280 cleaner
    Nine 1/2 foot deep end with diving board

  2. Back To Top    #2

    Join Date
    Jun 2011
    Long Beach, CA

    Re: Aqua Rite Reading "Cold"

    Remove and reseat the display circuit board.

    My guess is that the temperature sensor is failing and the cell will need to be replaced. It passes at the store because it is just like when you reset the display the cell works for a little while. How old is the cell?
    16k gal plaster with raised spa, Jandy DEV60 filter, 2 HP 2-speed SHPF Jandy Stealth pump
    Hayward Aqua Rite T-15 SWCG, Jandy LXi 400k BTU NG heater, 350 sq.ft. of Sun Star solar panels, TF-100 Test Kit, Dolphin s300i Cleaner
    Test Kits . Pool Math . Chlorine/CYA Chart . The SLAM Process

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts