Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Possible filter troubles...

  1. Back To Top    #1

    Join Date
    Dec 2014
    Location
    Santa Clara, CA
    Posts
    4

    Possible filter troubles...

    Not sure if this is normal: when I vacuum the pool, I see the junk that I'm vacuuming up getting sent out in the return lines. Is this an indication that I need new cartridge filters? Or perhaps something else is going on? If I need to consult a pool professional, what do I ask for? (I really don't want/need a service contract, all I'd be looking for is a one-time filter evaluation...). Any suggestions?

  2. Back To Top    #2
    wjr75's Avatar
    Join Date
    Jun 2013
    Location
    IL
    Posts
    816

    Re: Possible filter troubles...

    Sounds like a leak in the filter cartridge or else where in the filter. I have an auto pool cleaner but my pool was getting cloudy when my FC and other testing numbers were normal. It happened to me this year and had to replace them.
    Inground 22k gallon gunite 15x31 main pool, 15x7 wading pool/sunning deck, hot tub/with overflow (9' octagon with limestone top) & slide NSWG, Aqua Blue Pebble Sheen
    Filter dual cartridge Sta-rite 450sq/ft, TF-100 Test Kit
    Heater Raypak 2100 400k btu cupro-nickel exchanger
    Auto pool cover, Polaris 280 auto pool cleaner, Jandy AqualinkRS8 Remote Control System

  3. Back To Top    #3

    Join Date
    Dec 2014
    Location
    Santa Clara, CA
    Posts
    4

    Re: Possible filter troubles...

    Quote Originally Posted by wjr75 View Post
    Sounds like a leak in the filter cartridge or else where in the filter. I have an auto pool cleaner but my pool was getting cloudy when my FC and other testing numbers were normal. It happened to me this year and had to replace them.
    Thanks much for the reply.

    So would a good course of action be to replace out the cartridges? Is there a way of determining ahead of time if that's the issue? Just trying to figure what else it could be, to determine if the whole filter might need to be upgraded...

    (No auto cleaner involved; the pool is small, and I don't mind pushing around the manual vacuum. For me, it's kinda zen...)

  4. Back To Top    #4

    In the Industry

    Join Date
    May 2015
    Location
    PA
    Posts
    11

    Re: Possible filter troubles...

    Pictures of your equipment please. If you have a multiport valve the gasket could have gone bad and is bypassing your filter. Also make sure your hair and lint basket is in good shape, most of the bigger debris should be getting trapped in it.
    Service tech in the swimming pool industry.

  5. Back To Top    #5

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,077

    Re: Possible filter troubles...

    When did you last clean the cartridges?
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

  6. Back To Top    #6

    Join Date
    Dec 2014
    Location
    Santa Clara, CA
    Posts
    4

    Re: Possible filter troubles...

    Quote Originally Posted by duraleigh View Post
    When did you last clean the cartridges?
    Filters cartridges were cleaned out three weeks ago. I thought that I should be doing this once every three or four months; if it's got to be once a month, that's painful. (I clean out the pre-filter basket every couple of weeks). Are my servicing expectations off?

    Filter is Hayward SwimClear C3025; pump is Pentair IntelliFlo Variable Speed. I'll try to post pics...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •