Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Skimmer line won't prime

  1. Back To Top    #1

    Join Date
    Sep 2015
    Location
    Santa Maria california
    Posts
    3

    Skimmer line won't prime

    Hi pool people, I'm very new to this. first in ground pool. I built it myself. I filled it up Friday and could not get skimmer to draw water to pump. I was kind of panicked because I was worried about scale. I was finally able to switch 3w valve to spa, prime system then switch 3w valve to pool but only on pool vacuum. It worked fine but when I tried to switch 2w valve from vac to skimmer it lost prime and pump went into a alert mode. The only thing I can think of is pool equipment is elevated about 4/5 feet above water line and skimmer water is simply running back into pool? Any help for the green horn.
    20x40 IG gunite pebble tec clean and clear cartridge filter variable intelliflo easy touch control raised spa. Finished 9/25/15

  2. Back To Top    #2

    Join Date
    May 2013
    Location
    Long Island NY
    Posts
    419

    Re: Skimmer line won't prime

    Since your equipment is elevated 4 or 5 feet sounds like your lines have more air than water, pump needs constant water. Let us know when you find out for sure.
    19,000 gal - Vinyl IG - Sand filter -1.5hp. - Taylor k 2006 - Loop Loc cover

  3. Back To Top    #3

    TFP Guide

    Catanzaro's Avatar
    Join Date
    Jul 2014
    Location
    Monmouth County, New Jersey
    Posts
    2,187

    Re: Skimmer line won't prime

    Quote Originally Posted by Muleskinner2929 View Post
    Hi pool people, I'm very new to this. first in ground pool. I built it myself. I filled it up Friday and could not get skimmer to draw water to pump. I was kind of panicked because I was worried about scale. I was finally able to switch 3w valve to spa, prime system then switch 3w valve to pool but only on pool vacuum. It worked fine but when I tried to switch 2w valve from vac to skimmer it lost prime and pump went into a alert mode. The only thing I can think of is pool equipment is elevated about 4/5 feet above water line and skimmer water is simply running back into pool? Any help for the green horn.
    Try this:

    I do not know your set up, but only work with one return and skimmer. Now shut off the pump. Plug the skimmer (that you are having issues with), with either a Gizmo or something for a tight seal. Do not over tighten, just enough to seal. Now open the pump basket (plug the return line), and keep filling it with water until water fills to the top and spills over. Now, remove the plug for the return line and close the lid on the pump basket. Have someone turn on the pump and make sure the multi-port is on filter. When the pump is turned on, quickly remove the Gizmo in the skimmer (should only be a few turns), and wait 45-60 seconds. As long as your water is half way on the skimmer, you should be pulling water from that area and should stay primed. Then open up other skimmer and returns.

    If this does not work, then in my opinion, your valves could be closed or something went wrong with the installation. If I remember correctly, the elevation of the pump and filter could be even higher.

    Please add your "signature" for future reference. If you have the model # of the pump and filter, that would be helpful as my signature states.
    14,700 gallons IG Pool Vinyl Liner - Octal Circulation System
    Hayward Pro-Series 350 LB. Sand Filter Model # S270T - 2" Plumping
    Hayward CL2002 Chlorinator - Hayward Super Pump 2 HP Model # k48m2n111
    Hayward AQR9 SWG 25K Salt Cell & TF-100 Test Kit + Speed Stir
    Gulfstream HE125RA - 117K BTU Heat Pump - Date of Build is 11-2013

  4. Back To Top    #4

    Join Date
    Sep 2015
    Location
    Santa Maria california
    Posts
    3

    Re: Skimmer line won't prime

    Quote Originally Posted by Catanzaro View Post
    Try this:

    I do not know your set up, but only work with one return and skimmer. Now shut off the pump. Plug the skimmer (that you are having issues with), with either a Gizmo or something for a tight seal. Do not over tighten, just enough to seal. Now open the pump basket (plug the return line), and keep filling it with water until water fills to the top and spills over. Now, remove the plug for the return line and close the lid on the pump basket. Have someone turn on the pump and make sure the multi-port is on filter. When the pump is turned on, quickly remove the Gizmo in the skimmer (should only be a few turns), and wait 45-60 seconds. As long as your water is half way on the skimmer, you should be pulling water from that area and should stay primed. Then open up other skimmer and returns.

    If this does not work, then in my opinion, your valves could be closed or something went wrong with the installation. If I remember correctly, the elevation of the pump and filter could be even higher.

    Please add your "signature" for future reference. If you have the model # of the pump and filter, that would be helpful as my signature states.
    Good idea. I'll try when I get home
    20x40 IG gunite pebble tec clean and clear cartridge filter variable intelliflo easy touch control raised spa. Finished 9/25/15

  5. Back To Top    #5

    Join Date
    Sep 2015
    Location
    Santa Maria california
    Posts
    3

    Re: Skimmer line won't prime

    Just to follow up on skimmer problem. Concrete steak through skimmer return line. Re routed line and added a check valve at the pump. It's working great. BTW the gizmo did work to prime the line after I fixed it. A check valve was needed to hold the water in the line. Thanks for the help.
    20x40 IG gunite pebble tec clean and clear cartridge filter variable intelliflo easy touch control raised spa. Finished 9/25/15

  6. Back To Top    #6

    TFP Guide

    Catanzaro's Avatar
    Join Date
    Jul 2014
    Location
    Monmouth County, New Jersey
    Posts
    2,187

    Re: Skimmer line won't prime

    Quote Originally Posted by Muleskinner2929 View Post
    Just to follow up on skimmer problem. Concrete steak through skimmer return line. Re routed line and added a check valve at the pump. It's working great. BTW the gizmo did work to prime the line after I fixed it. A check valve was needed to hold the water in the line. Thanks for the help.
    Wow, a concrete stake through return line. Well, I am glad you remedied the problem.
    14,700 gallons IG Pool Vinyl Liner - Octal Circulation System
    Hayward Pro-Series 350 LB. Sand Filter Model # S270T - 2" Plumping
    Hayward CL2002 Chlorinator - Hayward Super Pump 2 HP Model # k48m2n111
    Hayward AQR9 SWG 25K Salt Cell & TF-100 Test Kit + Speed Stir
    Gulfstream HE125RA - 117K BTU Heat Pump - Date of Build is 11-2013

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •