Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Leaking water at the discharge port of AGP

  1. Back To Top    #1

    Leaking water at the discharge port of AGP

    I have an AGP and have learned lots in the last 3 years! That is not to say that I know anything at this point. Right now my situation is baffling. The pool water is leaking out through the discharge port as if the valve was still open for backwashing. I have taken the top of the Multi-Port system and do not see anything that would cause the water to leak out... HELP! PLEASE! What do I look for? Thanks for your help! jlovell

  2. Back To Top    #2

    Join Date
    Mar 2007
    Coastalish 'down easter'

    Re: Leaking water at the discharge port of AGP

    Welcome to TFP!!

    It's either the spider (a/k/a wagon wheel) gasket in the multiport or the 'tracks' that the gasket sits in are warped or broken The gasket should sit in the tracks, with the tracks tight against it, level - if you see any humps or wrinkles on the gasket, you need to replace it.

    As a practical matter, if vacuumed stuff isn't bypassing the filter and blowing right back into the pool, you can simply plug the discharge port and deal with the fix later 8)
    Luv& Luk

    Having done construction and service for 4 pool companies in 4 states starting in 1988, what I know about pools could fill a couple of books - what I don't know could fill a couple of libraries :-D

    POOL SCHOOL, TF Testkits, Jason's Pool Calculator, CYA vs. cl chart, (Just a few DARNED handy links!)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts