Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Cloud

  1. Back To Top    #1

    Join Date
    Apr 2015
    Location
    Buckeye, AZ
    Posts
    3

    Cloud

    Every time I backwash the filter then turn it on I get a nice Green cloud sent back into the Pool. Any Help out there?

  2. Back To Top    #2
    Texas Splash's Avatar
    Join Date
    Jun 2014
    Location
    South-Central Texas, Marion/San Antonio
    Posts
    12,934

    Re: Cloud

    Yikes. Green would seem to indicate you have algae settling into your filter from the water. Looks like it's time for you to conduct a SLAM via the Pool School - SLAM - Shock Level And Maintain. Do you have a TF-100 or Taylor K-2006 test kit to post a full set of readings for us?
    Pat (a.k.a. Texas Splash) ~ My Pool: Viking Fiberglass; 17,888 Gal; Waterway Supreme 2-sp/2-hp pump; Hayward Ctg filter; TF-100 w/ Speed Stir
    Vital Links: POOL SCHOOL, RECOMMENDED LEVELS, RECOMMENDED CHEMICALS, Poolmath Calculator, SLAM, Chlorine/CYA CHART.
    If you enjoyed your TFP experience, please consider donating to Support TFP!

  3. Back To Top    #3

    In the Industry

    Donldson's Avatar
    Join Date
    Jun 2009
    Location
    NW Ohio
    Posts
    2,636

    Re: Cloud

    Well any green is cause for concern, but to directly tackle your question: are you rinsing properly after you backwash?
    JD - 28' Round Above Ground Pool, 17,000 Gallons. Dual speed Jacuzzi pump with cartridge filter. Dual speed 1 HP pump, Hayward S210T sand filter
    Pool School - PoolMath - HIGHLY Recommended Test Kits

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •