Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Teledyne LAARS pool heater help

  1. Back To Top    #1

    Join Date
    Jul 2015
    Location
    Thousand Oaks, ca
    Posts
    13

    Teledyne LAARS pool heater help

    Hi guys,

    I bought a house that came with a somewhat dated SPA that was inoperable at the time. The seller pretty much got everything working except the pool heater. Per the previous owner, I ordered a new updated Integrated Pilot Module Ignition Control Circuit from Amazon, specifically this one:
    http://www.amazon.com/Honeywell-S8610U3009-Furnace-Intermittent-Control/dp/B000NWFFIM

    I hooked this one up and it would fire up the heater, uncontrollably. Specifically, when I hooked up the new board the heater would ignite itself and turn on full blast and there was no way to turn it off without disconnecting it, very dangerous. My friend in HVAC and a SPA guy we hired couldn't figure out how to set it up correctly. The SPA guy we hired recommended replacing with the same model circuit control board that was originally on the unit: s86a.

    I received a unit from ebay, which looked good, and hooked it up this morning, but I'm having trouble trying to figure out how to ignite the pilot and start it. I tried turning the knob to ON and pushing it down, but did not hear any clicking indicating the pilot was being ignited, like it did when I hooked up the amazon one (the one that would self-ignite automatically).

    I'm kind of stumped, so was looking for help. Here are some pictures of the heater:

    https://app.box.com/s/n3ygfcqwjwa6mh1lu0lkfetiyudbj5e0
    https://app.box.com/s/f01uvi5e84yww7ukfdwypwikvzey1zmu
    https://app.box.com/s/810471p4a2lvkto16irekhn3x9erno9o
    https://app.box.com/s/jbapdhzhdi9c8i0f0o09hskc79rv4df2

    Was hoping your knowledgeable folks could help out.

  2. Back To Top    #2

    Join Date
    Jul 2015
    Location
    Thousand Oaks, ca
    Posts
    13

    Re: Teledyne LAARS pool heater help

    So I got the heater working, I didn't turn on one of the switches. I left the pump and everything going for a good hour or so. The problem is that I found water leaking from inside the heater, as there was water coming from under it. There was a slight leak on the inlet joint water filter joint, which is easily fixable. What do you guys recommend on an old system like this? Fixing it or replacing everything?

  3. Back To Top    #3

    In the Industry

    Join Date
    Jun 2015
    Location
    Wildomar, California
    Posts
    423

    Re: Teledyne LAARS pool heater help

    You live in my neck of the woods. That is one old Laars heater! I think it's replacement time, especially if your exchanger is leaking.

  4. Back To Top    #4

    Join Date
    Jul 2015
    Location
    Thousand Oaks, ca
    Posts
    13

    Re: Teledyne LAARS pool heater help

    You're welcome to come by and check it out . When I fired it up again for another couple hours no water appeared by the heater this time. Spa guy quoted us $1,000 for a reconditioned unit and double that for a new one. Would like to see what I can do to get this guy running.

  5. Back To Top    #5

    Join Date
    Jul 2015
    Location
    Thousand Oaks, ca
    Posts
    13

    Re: Teledyne LAARS pool heater help

    Here are the main problems:

    Half of the time the
    thermostat control on and off switches are unresponsive.
    Sometimes the igniter will continue to spark even though the burners are on. When I back off the on the temperature gauge it sometimes helps stop the spark.

    I'm concerned that the heater will not self-regulate the temp, it got to 110F pretty quick today.

    I also notice a leak appear from the underside of the heater when I initially ran the heater, but I ran it again for a couple hours and it didn't appear again.

    Can someone guide me on next steps? I'm not much of engineer/electrician, so I need assistance with any technical jargon.

  6. Back To Top    #6

    Join Date
    Jul 2015
    Location
    Thousand Oaks, ca
    Posts
    13

    Re: Teledyne LAARS pool heater help

    I reattached all the wiring and cleaned off the high temp sensor. The heater seems to working fine now. I just need to find out if loud clicking sound I hear is normal when the temp gets close to desired setting.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •