Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Debris coming through filter

  1. Back To Top    #1

    Join Date
    Aug 2015
    Location
    Grand Haven, MI
    Posts
    2

    Debris coming through filter

    Hi Everyone,

    First season as a pool owner, the house we bought had 23,000 gallon, with a Tagelus TA-40 filter. I have noticed that when I vacuum up dead leaves, I can see bits of the leaves coming back through the return jets. Recently, I've been fighting some algae and noticed the same thing. If I vacuum up a large area of algae, I can see bits of it shooting back through the return jets. I had a pool store come out and replace the and and install disconnects on the PVC so I can do it myself next time, but it still does it. I tried adding a cup of DE to my skimmer, but after about a minute, I see it shoot out as a white cloud from the return jets. I've been fighting algae for a while now, but following the SLAM procedure on this site, to no avail. I get the feeling that my filter isn't doing anything. What else should I be looking at?

  2. Back To Top    #2
    Agent99's Avatar
    Join Date
    Aug 2008
    Location
    San Jose, CA
    Posts
    688

    Re: Debris coming through filter

    Have you taken your filter apart to see what is going on inside there? I don't know anything about your filter but it might be clogged or something damaged inside and the filter media is getting bypassed somehow.
    ----Chris----
    25k IG/Spa Figure 8, 18x36, Pebble Sheen Blue Granite, Sta-Rite S8M150 Cartridge Filter, Pentair 460805 400k BTU Heater & 011018 IntelliFlo VarSpd
    Liquidator, Fafco Solar Heat, Polaris PB460 Booster Pump w/280 cleaner, Katchaleaf Cover, TF100 Test Kit, FAKE MAIN DRAIN

  3. Back To Top    #3

    Join Date
    Aug 2015
    Location
    Grand Haven, MI
    Posts
    2

    Re: Debris coming through filter

    Do you mean the multi-port valve on top? The pool guys took the valve off the filter when they replaced the sand. I just noticed I typo'd my original post. I meant to say they replaced the sand. I haven't taken apart the multi valve itself.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •