Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: Pentair VS not turning on, no power

  1. Back To Top    #1

    Join Date
    Oct 2014
    Location
    San Marcos, Ca
    Posts
    62

    Pentair VS not turning on, no power

    My Pentair VS was off today when it should be on. I have 120v at both lugs on the Intermatic timer and there is power at the connections on the pump. The display is off completely as if there is no power to it.

    Any ideas?
    12,000 gallon IG plaster
    Cartridge filter
    Intellifo VS
    EasyTouch Controller
    Pentair SWG

  2. Back To Top    #2

    Re: Pentair VS not turning on, no power

    If the module failed, the most likely thing to go is the current protection thermistor. A fairly easy repair if you're handy with a soldering iron.

    If you're certain you have proper voltage at the pump connection, then I would check for smoked components on the controller.
    Of course, secure power first.
    24k gallon inground vinyl liner pool, 8'-3' depth, 2 skimmers, 3 returns, basic 5 chem kit.
    Hayward: DE-60 filter, Superpump VS, AquaRite salt chlorinator w/T-Cell 15, TigerShark QC robot. Jacuzzi hot tub ~350gal. Air blower type, w/8 jets.

  3. Back To Top    #3

    Join Date
    Oct 2014
    Location
    San Marcos, Ca
    Posts
    62

    Re: Pentair VS not turning on, no power

    There is 120v at both connections at the pump and grounds are secure at the timer and pump.

    I can solder. How do I access the thermistor and the controller components?

  4. Back To Top    #4

    Re: Pentair VS not turning on, no power

    First. You say 120v at each terminal to ground? You have to measure across the input terminals L1 to L2. If you don't have 240v then you have a bad breaker, bad timer, or broken connection from the power source.

    If you have 240v power going in, there is an open circuit somewhere in the pcb (printed circuit board). You have to open the housing and look for a failed component. Typically the failed component will have signs of overheating, black soot etc. I can't say for certain on your pump where it is or if it's the same, but many VS motor controllers use NTC or PTC thermistors to control overloading.
    More than likely if it's on the pcb it's a 1 Ω 20-30A NTC. NTC link
    If you can't read the component, you would have to check with the mfg. to get the correct size.

    Like I said, I can't say for certain this is your problem, but with variable speed drives transient current spikes are very damaging.
    24k gallon inground vinyl liner pool, 8'-3' depth, 2 skimmers, 3 returns, basic 5 chem kit.
    Hayward: DE-60 filter, Superpump VS, AquaRite salt chlorinator w/T-Cell 15, TigerShark QC robot. Jacuzzi hot tub ~350gal. Air blower type, w/8 jets.

  5. Back To Top    #5
    Mod Squad YippeeSkippy's Avatar
    Join Date
    Jan 2012
    Location
    'burbs of Augusta, Georgia
    Posts
    6,470

    Re: Pentair VS not turning on, no power

    While I can't help with the pump, I'd like to offer up that you can add liquid chlorine (aka "bleach") and keep it mixed up with brushing to help avoid algae while you work on the mechanicals.

    Use Pool Math app to help determine how much --> http://www.troublefreepool.com/calc.html
    My Amazon Smile for November12K Fiberglass IG, Infinity 4000 automatic cover, SWCG, Hayward Sand Filter, Hayward 1.5 Pump, Doheny Discovery Robot, Savi Melody LED pool lights, outdoor speakers and other assorted doo-dads. Sundance Altamar Hot Tub.
    Our pool build--> Our Pool Solved Our Sloping Yard Skippy's Cheap Pool Cooler -->Skippy's New Fountain

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •