Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Hayward H100ID heater only fires when ignition module is not grounded.

  1. Back To Top    #1

    Join Date
    Aug 2015
    Location
    marysville, pa
    Posts
    2

    Hayward H100ID heater only fires when ignition module is not grounded.

    I have replaced nearly every component on this nearly new heater. Last was the gas valve; installed & it fired fight up. I didn't need heat so turned the heater off. Today I want heat and it doesn't fire. I saw somewhere a guy said heleft his ig. Module just hang and it worked, so I tried it and sure enough it's firing. I don't feel good about doing this but I will make a permanent hanger if it's safe. Any thoughts?

  2. Back To Top    #2

    TFP Guide

    Join Date
    Jun 2012
    Location
    western NY
    Posts
    1,557

    Re: Hayward H100ID heater only fires when ignition module is not grounded.

    Can you post a picture of this "module" that you left hanging? I know there is a control board in there that the spark igniter runs off of. Is this what you are speaking about.


    A quick lesson on how these systems work.

    Thermostat initiates a call for heat.
    Board checks water temp sensor and confirms that the water is colder than the call for heat.
    The board starts the draft inducer fan and checks for the vacuum switch to close.
    The board then checks all safeties such as water pressure.
    Board sends signal to spark igniter
    Gas valve opens and unit fires .
    Unknown make 18' above ground (bought used in 1999) Sparco sand filter. Hayward 100,000 BTu heater. 2 speed pump

  3. Back To Top    #3

    Join Date
    Aug 2015
    Location
    marysville, pa
    Posts
    2

    Re: Hayward H100ID heater only fires when ignition module is not grounded.

    Danpik, yes it's the main control board. I just took the screw out that holds the aluminum (?) plate that the board mounts to the case & hung it so it didn't touch any parts of the heater & it fired. UPDATE: it stopped firing after a short while (half-hour?). So, I hung the plate back in place but removed the green grounding wire from the plate. Then it dired and ran for a while until I turned it off. 2nd UPDATE: today it doesn't fire! This is really frustrating. I could have bought another heater for all the money I spent trying to keep this thing running. From other corums I'm getting the info that says it's a really unreliable piece of junk.

    - - - Updated - - -

    Sorry for typos, trying to use cell phone.

  4. Back To Top    #4

    In the Industry

    ps0303's Avatar
    Join Date
    Jul 2011
    Location
    FL
    Posts
    3,437

    Re: Hayward H100ID heater only fires when ignition module is not grounded.

    Quote Originally Posted by thepoolboy View Post
    This is really frustrating. I could have bought another heater for all the money I spent trying to keep this thing running. From other corums I'm getting the info that says it's a really unreliable piece of junk.

    - - - Updated - - -

    Sorry for typos, trying to use cell phone.
    Yes sometimes you have to throw in the towel and start with a new heater and just enjoy the pool.

    I'd recommend a Raypak heater when you purchase the new one.
    Paul
    http://www.gastekservices.com A word of caution: When working with gas and electrical you might want to consider a licensed contractor. Consider the value of your life and others around you. If you would like to provide a review of the help I provided, please use the following link to leave a review. gastek - Google Search,

  5. Back To Top    #5

    TFP Guide

    Join Date
    Jun 2012
    Location
    western NY
    Posts
    1,557

    Re: Hayward H100ID heater only fires when ignition module is not grounded.

    I have one of these heaters on my pool. Been on there for the last 10 years. While I will agree that these are not the most reliable heaters, Mine has been fairly trouble free for the last 5 years and I don't treat it all that well. Drain the water for the winter and leave it out on the pad all winter long. I did have to replace the pressure switch once. For some reason unknown to me all of the components on it just exploded all over inside the housing. It never leaked from the bladder in the switch though. I bypassed it until the new one showed up and got installed. The only other problem I had, and I found this on several other of these, is the power connection pins on the circuit board have bad solder connections and need to be resoldered. For the price I paid (at the time $500 ) I can't really complain.
    Unknown make 18' above ground (bought used in 1999) Sparco sand filter. Hayward 100,000 BTu heater. 2 speed pump

  6. Back To Top    #6
    KDpoolguy's Avatar
    Join Date
    Mar 2017
    Location
    Palm Desert, CA
    Posts
    30

    Re: Hayward H100ID heater only fires when ignition module is not grounded.

    I'm having a similar issue with grounding if anyone wants to revisit this thread for me. I replaced nearly everything (PC Board, ICM, Thermostats, Potentiometers...).
    Here's the issue, as soon I place the thermostat cover on (Raypak old A265), the pilot lights, the ignitor stays on and main burner won't fire. I remove the thermostat cover, and keep it on my lap, the main burners fire up. I literally put the cover up to the unit and the main burners just flame out.
    I am somewhat confident that this is a grounding issue, but why and where? I did screw on the PC Board, and before I replaced it, it wasn't mounted to the back metal plate. The ground wire to the pilot/ignitor is kinda rusty. Any help is appreciated. _KD

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •