Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: MY Sand Filter Issues...

  1. Back To Top    #1

    Join Date
    Jun 2015
    Location
    Marysville WA
    Posts
    1

    MY Sand Filter Issues...

    It does not appear we have sand going back into pool, just cloudy milky water whenever we start the pump (Krystal Clear Sand Filter pump 1,200 gph (110 - 120V). Goes like this for about 15-30 seconds, then becomes clear again. Due to this our pool is extremely cloudy. We did clean out some gunk from the top of the sand a couple days ago, but this started before we did that, thinking it would solve it. Have used all the standard store-bought chemicals to bring all to their required levels, and still cloudy. We will check the laterals in the filter and see if there is something amiss there. thanks.
    Intex 18X9X52 Rectangular Ultra frame pool, 4545 gallons

  2. Back To Top    #2

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,077

    Re: MY Sand Filter Issues...

    Have used all the standard store-bought chemicals to bring all to their required levels,
    The chances are very good that it is still a chemistry issue - not filtration.

    As you read more, you will find TFP is all about precision testing and understanding what to do with the results. Please read "The ABC's of Pool Water Chemistry" up in Pool School. It may not seem related to your issue but your chemistry has to be correct before your filter can do it's job.
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •