Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Is that impeller broken?

  1. Back To Top    #1

    Join Date
    Jun 2015
    Location
    Holon
    Posts
    4

    Is that impeller broken?

    Hello everyone.

    My intex sand filter pump is making allot of noise. so after a quick search i found that intex bearings are of poor quality and need replacement so im taking care of that.
    However, when i checked the noisy pump i also noticed a licking from the impeller area. when i took the pump apart for the bearings i noticed there is a metal part with some rubber at the back of the impeller with a spring and i cant tell whether its broken or suppose to be like that. also the impeller is rotating off centric. can anyone tell me if its suppose to look like that or whether its broken?

    here is the back of the impeller:
    Impeler.jpg

  2. Back To Top    #2
    bobodaclown's Avatar
    Join Date
    Apr 2011
    Location
    Lakeland, FL
    Posts
    2,351

    Re: Is that impeller broken?

    That is the shaft seal.
    17K Kidney Shaped Pool Concrete (Diamond Bright) Pool, 3/4 hp 2 speed 115V Sta-rite Duraglas PEA5D-180L/P2R5D-181L (Impeller C105-92PS Diffuser C1-216P), 1.5 piping, Pentair CC100 Filter , Heat Siphon 100K BTU Heat Pump Pool Heater, Flow meter Blue White Flowmeter Model No. F-30150P, Hayward Astrolight SP0581N, SWCG CalimarTitanium Edition TE45 , Dolphin Nautilus Plus with CleverClean, Lakeland Florida

  3. Back To Top    #3

    Join Date
    Jun 2015
    Location
    Holon
    Posts
    4

    Re: Is that impeller broken?

    Quote Originally Posted by bobodaclown View Post
    That is the shaft seal.
    yes but is it broken? should you be able to see the spring?

  4. Back To Top    #4

    Join Date
    May 2008
    Location
    Northern California
    Posts
    71

    Re: Is that impeller broken?

    Yes, that is normal. You can see another picture at Step 16 here:

    How To Replace a Pool Motor Shaft Seal - INYOPools.com
    ============================================================ ===========================================
    12,000 gal. IG Colorquartz, 1.65hp Sta-Rite with 2-spd motor, 300sf cartridge, disabled SWG, AquaLogic P4, Polaris 280, gas+solar, 6' sheer descent with dedicated pump

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •