Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Sta-Rite Filter Issue

  1. Back To Top    #1

    In the Industry

    Join Date
    Jul 2015
    Chandler, AZ

    Sta-Rite Filter Issue


    I work as a pool tech and one of my customers recently purchased a set of filters for their cartridge filter. The label on the filter itself has been worn off from sun damage, so I can't tell the exact model of the filter but I ordered what my customer had last so it should fit. These are the filters I bought

    Sta-Rite S8M150-SET System 3 S8M150 Modular Media 450 - Small and Large Cartridge Replacement Kit

    I received them and installed them and the pool was pretty dirty so from what I've seen the PSI should have raised on the filter by quite a lot over night from filtering. The PSI didn't change at all, and I'm trying to figure out what could have happened. Could anyone help? Thanks for reading!

  2. Back To Top    #2

    In the Industry

    Join Date
    Jun 2015
    Wildomar, California

    Re: Sta-Rite Filter Issue

    Maybe it wasn't the filter cartridges. The heater could be limed up or stuck bypass, or such. Valves closed. Pump issues. You should examine there system and maybe run the filter without the cartridges to see if that is different.

  3. Back To Top    #3

    Join Date
    Sep 2014
    Bakersfield, CA

    Re: Sta-Rite Filter Issue

    That's a 450 sq ft cartridge filter. My 400 sq ft Sta-Rite System 3 lasts for up to a year before it needs cleaning.

    If the filter has cleaned up the pool then stop worrying about it, the filter is working fine.
    Cheers, Peter
    20,000 gal, 52'x17' kidney shaped IG, Pebble Tec, IntelliPro P6E6VS4H-209L pump. Intellichlor IC40 SWG.
    300 sf Sta-Rite System 3 cartridge filter. Poolvergnuegen 4-wheel suction pool cleaner. TF-100 test kit.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts