Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Aqua Rite Continual/Recurring PCB Error

  1. Back To Top    #1

    Join Date
    Jul 2015
    Port Orange / Florida

    Aqua Rite Continual/Recurring PCB Error

    So, last week we started having an issue with our chlorinator where none of the lights were staying on. After doing research on here, we replaced the delimeter. The chlorinator worked for a day and then started reading low salt. We added salt to it and the next day it started reading PCB on the display screen. We researched again and found two suggestions. 1 - remove power source for one minute and then plug back in. This worked!! Unfortunately, it only worked for a day. 2 - recalibrate the default salt reading. We did this and it too worked, for a day. Now, every day the PCB error comes back. Does anyone have any other ideas?? We're about stumped. I can't find anything that talks about the error coming back daily.

  2. Back To Top    #2
    robdac's Avatar
    Join Date
    Jun 2014
    Weston, FL

    Re: Aqua Rite Continual/Recurring PCB Error

    I'm not sure what you mean when you say you replaced the delimeter and now have a PCB error. Can you please explain further?

    How old is the salt cell? When they get to the end of their useful life one of the first signs it's time to get a new one is a low salt error. Have you tested the salt level independent of the SWG? If so, what was the level. You may have added salt that the system does not need.
    11K gal IG screened-in plaster pool w/ spa
    pentair 150 cartridge filter, Pentair Intelliflow VS pump,
    Aquarite AQR15 SWG, AquaCal Heatwave Heat Pump, TF-100 test kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts