Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: l-shape o-ring

  1. Back To Top    #1

    Join Date
    Jul 2015
    Location
    Asheville N.C.
    Posts
    2

    l-shape o-ring

    This is the L-shaped O-ring from the pump to the filter on my 14" Intex sand filter. It is the one next to the pump. The one at the filter is just a little damaged. The rest look good. What could cause this?

    IMG_0441.jpgIMG_0442.jpg

  2. Back To Top    #2
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    37,389

    Re: l-shape o-ring

    Welcome to TFP!!!

    If the pump was ever allowed to run a good bit of time without water flow, it could have overheated and cause the damage to the seal. Or could there have been high strength chemicals passing directly through the pump?
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  3. Back To Top    #3

    Join Date
    Jul 2015
    Location
    Asheville N.C.
    Posts
    2

    Re: l-shape o-ring

    Thank you. Chemicals may be off a little but nothing out of the ordinary. Over heating was what I thought but it was running fine and on the timer when I left. I will check every thing and start it back up.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •