Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 9 of 9

Thread: Cloudy pool after backwash and didn't use rinse cycle

  1. Back To Top    #1

    Join Date
    Jul 2015
    Location
    Rowlesburg,WV
    Posts
    4

    Cloudy pool after backwash and didn't use rinse cycle

    We have never had to backwash our filter because it was installed late last year. When we used backwash cycle we were unaware that you had to use rinse cycle following. All of the debris went into our pool and we have been running filter non stop to clear it up. Any suggestions? We have a Hayward Sand Filter.

  2. Back To Top    #2
    Mod Squad YippeeSkippy's Avatar
    Join Date
    Jan 2012
    Location
    'burbs of Augusta, Georgia
    Posts
    6,470

    Re: Cloudy pool after backwash and didn't use rinse cycle

    Do you have a little pool DE you can add to your sand filter to aid in the pickup? Perhaps a friend has a DE filter and could give you a cup or so?

    oh yeah...I forgot my manners....Welcome to TFPC
    My Amazon Smile for November12K Fiberglass IG, Infinity 4000 automatic cover, SWCG, Hayward Sand Filter, Hayward 1.5 Pump, Doheny Discovery Robot, Savi Melody LED pool lights, outdoor speakers and other assorted doo-dads. Sundance Altamar Hot Tub.
    Our pool build--> Our Pool Solved Our Sloping Yard Skippy's Cheap Pool Cooler -->Skippy's New Fountain

  3. Back To Top    #3

    Join Date
    Jul 2015
    Location
    franklin/tn
    Posts
    93

    Re: Cloudy pool after backwash and didn't use rinse cycle

    I just bought a box of hth de at amazon. Planning to use a little in my sand filter to help me clean up this algae bloom

  4. Back To Top    #4
    Mod Squad zea3's Avatar
    Join Date
    Jul 2009
    Location
    Houston, Texas
    Posts
    9,198

    Re: Cloudy pool after backwash and didn't use rinse cycle

    You may want to turn the pump off and let everything settle on the floor of the pool overnight, then vacuum as much as you can to waste. After vacuuming, top off the water and raise the chlorine to shock level. Keep running the pump and filter after vacuuming and see if the water clears any.

    You may need to complete the SLAM process to kill off any algae that may have been dumped back into the pool. Can you post a picture of how the pool looks now?
    TFP Moderator
    Helpful links: TF Test Kits,TFP Pool School, PoolMath
    Vogue 21' round AG, Pentair 1 hp 2 speed pump, 36 sq ft DE filter, Hayward S180T 150# sand filter, Houston, Texas
    Love TFP? Become a
    TFP Supporter!

  5. Back To Top    #5

    Join Date
    Jul 2015
    Location
    Rowlesburg,WV
    Posts
    4

    Re: Cloudy pool after backwash and didn't use rinse cycle

    Everyone around me has sand or cartridge filters. Thanks for the Welcome! Will check around. Thanks!

  6. Back To Top    #6

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,077

    Re: Cloudy pool after backwash and didn't use rinse cycle

    Well, you could look at it like this....your sand filter caught that dirt and debris once, there is no reason to think it won't catch it again.

    I would vacuum as much as I could and then brush up the pool often to keep the debris suspended until the filter takes it right back out.
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

  7. Back To Top    #7

    Join Date
    Jul 2015
    Location
    Rowlesburg,WV
    Posts
    4

    Re: Cloudy pool after backwash and didn't use rinse cycle

    We tried the drop and vac method and it did settle everything to the bottom, but when we vacuumed it stirred it all up again. We tried shocking it with xtra blue that has algae killing crystals in it and that didn't help either. Unfortunately I have no way to post a picture but can describe. The water is blue just very cloudy and you can see what the liner looks like at the very top all around the pool for about a foot down and then very cloudy.

  8. Back To Top    #8

    Join Date
    Jul 2015
    Location
    Rowlesburg,WV
    Posts
    4

    Re: Cloudy pool after backwash and didn't use rinse cycle

    Update: Vacuumed pool for 4 hours this morning and pool did clear up a little. There was a slight green tint so I added algaecide about 20oz. Has been about 5 hours and pool is still cloudy. I checked my levels with aqua chem test kit (I know) unfortunately we live in the country and its 30 minutes just to Walmart but my levels are off the charts everything reading High. With test strips also. Suggestions?

  9. Back To Top    #9

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,077

    Re: Cloudy pool after backwash and didn't use rinse cycle

    Welcome to the forum.

    Algaecide is not correct to kill algae.....chlorine is far better.

    So if everything is "off the charts everything reading High" then I guess you are stuck with trying to get things lowered. If you can post real numbers, we may be able to suggest something.
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •