Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Aqua Rite Pro - "check system" light on, LED only displays "Check System"

  1. Back To Top    #1

    Join Date
    Jul 2015
    Location
    Houston, Texas
    Posts
    7

    Aqua Rite Pro - "check system" light on, LED only displays "Check System"

    I have an Aqua Rite Pro. The "Check System" light is lite and the LED only displays "Check System". If you push any of the buttons on the unit nothing happens. I have a pool guy (just bought the house and had no experience with pools) says I need a new board. When I called Hayward they asked if it was the control unit (part GLX-CTL-AR-PRO) or the PCB unit (GLX-PCB-AR-PRO). Does anybody know which part I need to purchase?

  2. Back To Top    #2
    Casey's Avatar
    Join Date
    Apr 2007
    Location
    SW PA
    Posts
    10,157

    Re: Aqua Rite Pro - "check system" light on, LED only displays "Check System"

    Welcome to TFP!

    I'm not sure but someone else may know.

    I'd bet you my bikini you'll never get TFP water from a pool store!

    24' Sharkline Venture De Filter

  3. Back To Top    #3
    Thimble's Avatar
    Join Date
    Apr 2013
    Location
    Wichita, KS
    Posts
    93

    Re: Aqua Rite Pro - "check system" light on, LED only displays "Check System"

    It may be as simple as your SWG needs cleaning. You can find directions in Pool School-Pool Equipment-Salt Water Chlorine Generators. Cleaning directions are included in the maintenance section.

    My Aqua Rite gives me a "check system" light about every 3 months. If I remember right, it does this automatically after X hours of operation as a reminder. I check the cell for build up ( which it never has), do a reset and it's good to go for another 3 months.

    I'm willing to bet yours is fine, it's just nagging you a little.
    15x30 IGP; 20,000 gallons; plaster
    Hayward SP2607X10 Pump; Purex Triton Tagelus Sand Filter
    Hayward Goldline T-Cell 15 SWG; Aquarite G1 Control
    Southwest Spas 400 gallon hot tub w/ozone
    TF 100 with speed stir

  4. Back To Top    #4

    Join Date
    Jul 2013
    Location
    Waxahachie, Tx.
    Posts
    424

    Re: Aqua Rite Pro - "check system" light on, LED only displays "Check System"

    I have an Aqua Rite, not a Pro. Mine does not have a "check system" light. I have an " inspect cell" light that comes on every 500 hours of operation as a reminder. To rest it I press and hold the diagnostic pushbutton for 3 sec's.
    12 x 26 Viking FG IG, Bermuda Model, 3 1/2' to 5', 7000 Gallons, Diamond Series Maya, Hayward 1 1/2 HP Maxflo VS, Hayward Stay Clear Plus Cart Filter C17502(S), Hayward Aqua Rite SWG w/T3 cell, Color Changing FIBERSTAR Lighting, Aqua Bot Supreme Robotic cleaner, Brushed Concrete with CCI Liberty Tan color, Taylor K-2006 test kit, Armor Foundation penetrating concrete sealer(lifetime warranty).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •