Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 7 of 7

Thread: Polaris 360 moving but not vacumming

  1. Back To Top    #1

    Join Date
    Jul 2015
    Location
    Conroe texas
    Posts
    1

    Polaris 360 moving but not vacumming

    Hello, I am a new pool owner and our polaris pool cleaner recently stopped sucking up debris. I cleaned the filter in the hose. It still moves around the pool and the tails moves but it is not sucking anything up. Any suggestions?

  2. Back To Top    #2
    Casey's Avatar
    Join Date
    Apr 2007
    Location
    SW PA
    Posts
    10,157

    Re: Polaris 360 moving but not vacumming

    Welcome to TFP.

    Someone should be around to help you. I would but I don't have an auto cleaner.
    I'd bet you my bikini you'll never get TFP water from a pool store!

    24' Sharkline Venture De Filter

  3. Back To Top    #3

    In the Industry

    Join Date
    Dec 2013
    Location
    PA. USA
    Posts
    26

    Re: Polaris 360 moving but not vacumming

    Try holding it out of water, and see if the small jets are shooting water into the bag.

  4. Back To Top    #4

    In the Industry

    Join Date
    Jun 2015
    Location
    Wildomar, California
    Posts
    423

    Re: Polaris 360 moving but not vacumming

    Check that the throat doesn't have something in it. And check the jets throwing up the water.

  5. Back To Top    #5

    Join Date
    Aug 2015
    Location
    Torrance, CA
    Posts
    3

    Re: Polaris 360 moving but not vacumming

    Just had the same problem with my 380. Remove the bag and look down the throat at the jets. Mine had little pieces of plastic debris stuck in the jets. I tried using a long piece of wire to try and dislodge the debris but after multiple failed attempts, ended up disassembling and cleaning.

    FYI you may want to check your in-line filter. I checked mine and lo & behold it was missing altogether... Bought replacement for $10

  6. Back To Top    #6

    Join Date
    Jun 2017
    Location
    Godley
    Posts
    2

    Re: Polaris 360 moving but not vacumming

    Hello I'm having the exact same problem. Were you ever able to solve the problem? If so please share thank you

  7. Back To Top    #7

    Join Date
    Mar 2013
    Location
    Shawnee OK
    Posts
    26

    Re: Polaris 360 moving but not vacumming

    Quote Originally Posted by boodles View Post
    Hello I'm having the exact same problem. Were you ever able to solve the problem? If so please share thank you
    Rose this thread from the dead. The 360 and 380 are very simple machines. They use water jets point UP from the bottom of the cleaner. This creates a suction effect. If you run the cleaner and pull it from the water, you should see those 3 jets spraying up the center. If they are not, then the nozzles are clogged. Time to take it apart and clean them out. You should also ensure that your filters are in place. I have an inline filter in addition to the filter at the wall fitting. This was before I moved to hair nets in my skimmer basket- that has been the biggest, cheapest solution for cleaning so far in my 6 years of pool learning.
    20k gal vollyball pool, IG, Vinyl, Sand filter, 1hp Pentair Superflo Dual Speed main pump 340042 (2016), 3/4hp Polaris PB4-60 booster pump (2015), Polaris 380 cleaner & Hasa Liquidator w/3/8" upgrade (2013).
    Pool approx 10 years old, liner at least 4 years old.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •