Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 10 of 10

Thread: Top panel blew off IIntelliChlor IC40

  1. Back To Top    #1

    Join Date
    Apr 2008
    Location
    StL, MO
    Posts
    49

    Top panel blew off IIntelliChlor IC40

    Returned home from weekend getaway and when I went to close valve for main drains before vacuuming I saw that the top panel of my IC40 had blown clean off. Noticed a black mark on the inside of the white cover that looked like an electrical burn and another burn on the exposed black membrane that is beneath the white cover. Strange thing is the cell was still reading the salt level and showing output when I went to Diagnostics on my EasyTouch. Cycled the breakers but the cell's indicator lights are out.

    Thoughts? Haven't checked the fuse in the power center yet. Ugh!

  2. Back To Top    #2

    Re: Top panel blew off IIntelliChlor IC40

    Sounds like you're going to need a new cell. How old is it?

    Can you post a picture?

  3. Back To Top    #3

    Join Date
    Apr 2008
    Location
    StL, MO
    Posts
    49

    Re: Top panel blew off IIntelliChlor IC40

    It turned 3 in March. I'll post photos shortly.

  4. Back To Top    #4

    Join Date
    Apr 2008
    Location
    StL, MO
    Posts
    49

    Re: Top panel blew off IIntelliChlor IC40

    image.jpg

    - - - Updated - - -

    image.jpg

  5. Back To Top    #5
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    23,999

    Re: Top panel blew off IIntelliChlor IC40

    Wow! First time I've seen that! Bummer!
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  6. Back To Top    #6
    Mod Squad Jimrahbe's Avatar
    Join Date
    Jul 2014
    Location
    Bedford, TX
    Posts
    5,341

    Re: Top panel blew off IIntelliChlor IC40

    Sorry, but it is time to bend over and kiss your IC40 good-bye...

    I take care of an electronics repair department (Nothing to do with pool stuff) but based on personal experience with things that look similar to this, I'm pretty sure that it is toast.

    Jim R.
    Finished in 2015 - 17K Gal, IG, 20' x 25' Almost Rectangular Pool, Pebble finish, three rockport water falls. Pentair Equipment: EasyTouch 4, IC40 SWG, 3 HP VS Pump, CCP520 Cartridge Filter.
    TF100 with SpeedStir and SampleSizer, ColorQ Pro 7, Dolphin Premier Robot Cleaner, added Screen Logic 2, added small 3 person Calder Spa.

  7. Back To Top    #7

    Re: Top panel blew off IIntelliChlor IC40

    I have seen this happen before. In the case I have seen there was water intrusion into the electronics. It looks like this is a similar situation.

    Time for a new cell.

  8. Back To Top    #8

    Join Date
    Apr 2008
    Location
    StL, MO
    Posts
    49

    Re: Top panel blew off IIntelliChlor IC40

    Thanks both. I was thinking the same thing. Again, ugh.

  9. Back To Top    #9
    jrs_diesel's Avatar
    Join Date
    Aug 2014
    Location
    League City, TX
    Posts
    215

    Re: Top panel blew off IIntelliChlor IC40

    You didn't have a recent thunderstorm did you?
    J.R.

    20K IG gunnite pool
    2HP Hayward single speed pump
    Cartridge filter

  10. Back To Top    #10

    Join Date
    Apr 2008
    Location
    StL, MO
    Posts
    49

    Re: Top panel blew off IIntelliChlor IC40

    Correction, I replaced the cell last June. I've replaced so much Pentair equipment since our pool was built in September 2007 I can't keep it all straight. Pentair has agreed to replace the cell out of warranty!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •