Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Mold and Poly Sand issues with my Belgard Mega-Arbel Pool Deck

  1. Back To Top    #1

    Join Date
    Jan 2013
    Location
    Texas
    Posts
    39

    Mold and Poly Sand issues with my Belgard Mega-Arbel Pool Deck

    Hi All,

    I live in San Antonio Texas and have a pool deck that uses mostly Belgard Mega-Arbel with Polymeric Sand between the joints. I have had the pool for only two years and yet I have had recurring problems with the Polymeric Sand. It has actually been replaced once already and I had the whole deck sealed at that point in time. However, now I think I might need to replace it again. I think my pool builder went out of business so no option to turn there for help. Here are the problems that I am having:

    1) Polymeric Sand in the pool. This is a relatively minor issue in that every time I clean the pool, I can get most of the visible sand, however, it just keeps coming back. I'm not sure whether more is washing into the pool or whether its just settling out of the water constantly. I have replaced the filter early in the season and it did not appear to have any effect. The biggest problem I think is that the poly sand seems to settle out into my pool lights (or maybe that's just algae?). I have included some pictures of my Pal LED pool lights. I'm not sure if there is a problem with the way the light was installed (these have already been replaced once as well) or whether it is normal for water to be inside of the light housing.

    2) Moldy polymeric sand. I think maybe the poly sand was not installed correctly or maybe it was a bad or cheap batch. We did have a ton of rain this spring so that is probably part of the problem. The sand seems to be loose in a lot of places and to have washed out of the grooves in some places and in others, mold has formed in the sand. As you can see from the pictures, the once tan looking sand is now black in many places.

    I am hoping someone can give insight into both the LED light problems and the poly sand problems. I have posted for help from contractors and have received three different responses:

    1) One wants to remove all of the poly sand with Techniseal Slurry Remover and then resand the pool deck and just replace the pool lights. My main problem with this is that I am wondering if I will be back in the same situation next year.

    2) One wants to remove all of the poly sand and then replace with Mortal instead of Poly Sand. He also wants to replace the pool lights, but put some silicon sealer around the lights to keep water from getting in. I like both of these ideas, but I am not sure whether mortar can be used with the Mega Arbel and Belgard recommends poly sand. Mega Arbel is a paver that is made to look like flagstone and it has the grooves built into the paver that don't extend all the way to the underlying surface so it seems to me that it would be a lot less likely for the mortar to crack over time. Anyone ever use mortar with Mega Arbel?

    3) One says he can just remove the mold. Of course, this doesn't solve the problem with the sand washout into the pool.

    Any help or insight that you may have would be greatly appreciated. I have included pictures of the pool deck including closeups of some of the moldy areas as well as the lights. Also, anyone know if these kind of Pal lights can be just cleaned up and reused. They are tri color LED lights and 2 of the 3 seem to work fine despite the unsightly appearance.






    Pool Build in Progress: 29' kidney bean shaped fiberglass pool, Tuscany model from Leisure Pools, 12400 gallons, 1 1/2 HP Pentair Whisperflo pump, Pentair Intelliflo Salt System 40, 200 square feet Pentair cartridge filter, 1 skimmer w/ 3 returns, LED lighting, Belgard Mega-Arbel pavers.

  2. Back To Top    #2

    Re: Mold and Poly Sand issues with my Belgard Mega-Arbel Pool Deck

    Does the rain runoff from the pavers into the pool?

    Water inside the housing sounds like the lights are defective, or the niche was installed incorrectly. Have you reached out to the lighting company? They would have an area company rep that could be helpful.
    8.5k gallon IG pebble sheen play pool with Intellitouch control, Intellifo VF, IC 20, Rainbow tab feeder (not currently in use), Pentaire mystery cartridge filter with labels faded to the point I have no idea on the model, Intellibrite 5g LED light, Hayward Navigator. Adding IntelliPh and Crestron control next.

  3. Back To Top    #3

    Join Date
    Jan 2013
    Location
    Texas
    Posts
    39

    Re: Mold and Poly Sand issues with my Belgard Mega-Arbel Pool Deck

    Quote Originally Posted by dtlight View Post
    Does the rain runoff from the pavers into the pool?
    The pool builder built the pool so that water would run off the deck into a drain and not into the pool. There is a drain where the pool deck meets the composite deck.

    Quote Originally Posted by dtlight View Post
    Water inside the housing sounds like the lights are defective, or the niche was installed incorrectly. Have you reached out to the lighting company? They would have an area company rep that could be helpful.
    I haven't reached out to the lighting company, the lights were installed by my pool builder who is out of business. I'll see if I can find a rep from the lighting company who might be able to give some insight. Thanks!
    Pool Build in Progress: 29' kidney bean shaped fiberglass pool, Tuscany model from Leisure Pools, 12400 gallons, 1 1/2 HP Pentair Whisperflo pump, Pentair Intelliflo Salt System 40, 200 square feet Pentair cartridge filter, 1 skimmer w/ 3 returns, LED lighting, Belgard Mega-Arbel pavers.

  4. Back To Top    #4

    Re: Mold and Poly Sand issues with my Belgard Mega-Arbel Pool Deck

    Presuming you pool builder had a valid contractors license and bond, the state contractors licensing board may be of some help as well.
    8.5k gallon IG pebble sheen play pool with Intellitouch control, Intellifo VF, IC 20, Rainbow tab feeder (not currently in use), Pentaire mystery cartridge filter with labels faded to the point I have no idea on the model, Intellibrite 5g LED light, Hayward Navigator. Adding IntelliPh and Crestron control next.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •