Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Ecomatic ESC 6000 not powering on

  1. Back To Top    #1

    Join Date
    Jul 2015
    West Palm Beach, Florida

    Angry Ecomatic ESC 6000 not powering on

    I have an ecomatic esc 6000, about 3 years old, and it suddenly stopped working. No lights, nothing when it's turned on.
    The cell is clean and there is power getting to the power pack.
    I'm wondering if the motherboard blew or transformer? Is this something common that happens with these in 3 years time?
    I have a non-contact voltage tester and when I hold it up to the power cord, it beeps.
    When I hold it up the the power pack to the left of the on switch, it does nothing when it's off, then when I turn it on...the tester beeps.
    I checked the fuses and they look fine. but I'm going to buy two more just to be sure.
    Anything else I can do to troubleshoot? I can't imagine this thing is dead already.

    Any help would be appreciated.

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    SouthWest Alabama

    Re: Ecomatic ESC 6000 not powering on

    A small multimeter would help a lot. It would allow you to check the transformer at very least. And you'll be able to test the fuses definitively.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts