Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 9 of 9

Thread: Hayward 6060 booster pump leaking at top

  1. Back To Top    #1

    Join Date
    Jul 2015
    Location
    Conshohocken, PA
    Posts
    1

    Hayward 6060 booster pump leaking at top

    The pipe going in the top has a leak. When I turn the cleaner on the water spews out. Tonight I took it apart and the o-ring was laying on top of bottom pipe. Put o ring back in place, still leaking just not as bad. Is this as simple as replacing the o-ring?

  2. Back To Top    #2
    Patrick_B's Avatar
    Join Date
    Jun 2011
    Location
    Midland TX
    Posts
    15,001

    Re: Hayward 6060 booster pump leaking at top

    Welcome to the forum!

    Sure sounds like it would be worth a shot in this situation. I'd give it a try for certain and see what happens.
    TFP Moderator
    Essential Links:
    ABC's Of Pool Chemistry, Test Kits, SLAM Your Pool
    28K Gal IG FreeForm, CLI Quartz, Pentair 36"SF & VS Pump, Dolphin M5, Rheem

  3. Back To Top    #3

    In the Industry

    Hayward Pool's Avatar
    Join Date
    Oct 2014
    Location
    Elizabeth
    Posts
    415

    Re: Hayward 6060 booster pump leaking at top

    I am assuming that the union is being used. The o-ring should solve the problem. Here is a link to the manual

    http://www.hayward-pool.com/pdf/manu...rPump-6060.pdf
    Hayward Pool Tech
    80+ Years of Technologically Advanced Pool Product Manufacturing
    poolside@haywardnet.com

  4. Back To Top    #4

    Join Date
    May 2015
    Location
    Austin, TX
    Posts
    21

    Re: Hayward 6060 booster pump leaking at top

    Quote Originally Posted by Hayward Pool View Post
    I am assuming that the union is being used. The o-ring should solve the problem. Here is a link to the manual

    http://www.hayward-pool.com/pdf/manu...rPump-6060.pdf
    same pump, same problem for no apparent reason. Changed o-ring, still leaks. Oversized o-ring, still leaks. I am thinking it is possible a crack in the union piece, but I will have to cut the pipe off to see the fitting and inspect. I sure hope it is not the threaded port on the pump as that is part of the pump housing.
    16x30 gunite/plaster, 15,500 gal, Flagstone coping, 3'-6' depth plus bench and sundeck, bubbler, Hayward 1-1/2hp 2pd Tristar pump, Hayward 550 cartridge filter, 320 Chlorinator, Smart Ozone Sanitizer, Hayward Viper cleaner, 1 skimmer, 2 drains, 3 returns, 1 deck bubbler, Hayward booster pump for cleaner. Taylor K-2006 test kit.

  5. Back To Top    #5

    Join Date
    May 2015
    Location
    Austin, TX
    Posts
    21

    Re: Hayward 6060 booster pump leaking at top

    just reading this, it tells me this must be an inherent problem with these. Too too coincidental.
    16x30 gunite/plaster, 15,500 gal, Flagstone coping, 3'-6' depth plus bench and sundeck, bubbler, Hayward 1-1/2hp 2pd Tristar pump, Hayward 550 cartridge filter, 320 Chlorinator, Smart Ozone Sanitizer, Hayward Viper cleaner, 1 skimmer, 2 drains, 3 returns, 1 deck bubbler, Hayward booster pump for cleaner. Taylor K-2006 test kit.

  6. Back To Top    #6

    In the Industry

    Hayward Pool's Avatar
    Join Date
    Oct 2014
    Location
    Elizabeth
    Posts
    415

    Re: Hayward 6060 booster pump leaking at top

    I checked with engineering and technical and nothing has been reported. Let me know if you find something.
    Hayward Pool Tech
    80+ Years of Technologically Advanced Pool Product Manufacturing
    poolside@haywardnet.com

  7. Back To Top    #7

    Join Date
    May 2015
    Location
    Austin, TX
    Posts
    21

    Re: Hayward 6060 booster pump leaking at top

    I bought a new Hayward 1-1/2 union AX6060UNPAK and problem solved. Of course I had to create a new pipe section and add a union. Why Hayward makes us buy two of these in a kit is kind of a rip off. As I only needed the one.
    16x30 gunite/plaster, 15,500 gal, Flagstone coping, 3'-6' depth plus bench and sundeck, bubbler, Hayward 1-1/2hp 2pd Tristar pump, Hayward 550 cartridge filter, 320 Chlorinator, Smart Ozone Sanitizer, Hayward Viper cleaner, 1 skimmer, 2 drains, 3 returns, 1 deck bubbler, Hayward booster pump for cleaner. Taylor K-2006 test kit.

  8. Back To Top    #8

    Join Date
    May 2015
    Location
    Austin, TX
    Posts
    21

    Re: Hayward 6060 booster pump leaking at top

    FURTHER UPDATE, started leaking again. Bought a new volute thinking the fitting on the volute may be the problem. Installed and still leaks, so with a new volute, and a new line fitting, I am a at a complete loss. I did notice just tilting the pump slightly can cause it to leak. This means the fitting must be completely level and flush, but again this is almost impossible to do. I am going to try and find a better o-ring to see if this helps otherwise I will just go buy a new Polaris pump as I never had this issue with them.
    16x30 gunite/plaster, 15,500 gal, Flagstone coping, 3'-6' depth plus bench and sundeck, bubbler, Hayward 1-1/2hp 2pd Tristar pump, Hayward 550 cartridge filter, 320 Chlorinator, Smart Ozone Sanitizer, Hayward Viper cleaner, 1 skimmer, 2 drains, 3 returns, 1 deck bubbler, Hayward booster pump for cleaner. Taylor K-2006 test kit.

  9. Back To Top    #9
    Agent99's Avatar
    Join Date
    Aug 2008
    Location
    San Jose, CA
    Posts
    688

    Re: Hayward 6060 booster pump leaking at top

    Have you tightened the you know what out of the threaded connection? Use pipe dope (shouldn't need it but wouldn't hurt) and lubed up the o-ring good with a silicone lube (don't use a petroleum based lube like vaseline)?
    ----Chris----
    25k IG/Spa Figure 8, 18x36, Pebble Sheen Blue Granite, Sta-Rite S8M150 Cartridge Filter, Pentair 460805 400k BTU Heater & 011018 IntelliFlo VarSpd
    Liquidator, Fafco Solar Heat, Polaris PB460 Booster Pump w/280 cleaner, Katchaleaf Cover, TF100 Test Kit, FAKE MAIN DRAIN

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •